My Facebook Photo disappeared for 24 hours

4 min read

TL:DR: Photos posted to a Facebook page disappeared for a while. Strange behavior by scheduler on the day suggests possible server problems but links on the photos flagged as spam may also be the culprit.

 

My facebook page consists mostly of photos. I post 1-2 per day. The page started a few months before the incident and had about 2200 followers.

 

The preamble

On Monday, I scheduled two photos: one for Tuesday and one for Wednesday. They appeared in the timeline on schedule.

The Wednesday photo became a runaway success with over 200,000 views & 1000 shares.

On Thursday I posted a whole album plus a single photo for the timeline. The Wednesday photo was still enjoying some fame but this was starting to die down.

Late Thursday afternoon, I also scheduled another photo for Friday.

At this point in the story, 3 photos had been published (1 each day Tuesday, Wednesday, Thursday) and 1 was scheduled. An album had also been published.

 

The downfall

At around 8pm Thursday evening, I noticed the photo I had scheduled for Friday had been published to the timeline with a time of noon Thursday (My timezone is GMT +8). It was as if the scheduler had retroactively put it on the timeline for Thursday instead of Friday .

I thought it weird I didn’t notice it before. I figured it must have been my fault. I deleted that post then re-uploaded it and scheduled it again for Friday.

An hour later, the same thing happened. And this time I knew it wasn’t my mistake. I deleted the photo again and left for a late supper. I would sort it out later.

 

Gone

When I got back at 11pm, both the Tuesday and my amazing Wednesday photo had disappeared. I was gutted.

The links to the photos displayed the following message:

The page you requested cannot be displayed at the moment. It may be temporarily unavailable, the link you clicked on may have expired, or you may not have permission to view this page.

Oddly, so had the photo album I had uploaded… but just the album: not the photos in the album. So there were 11 photos that were “albumless” and could not even be moved to a new album. A definite technical glitch.

Also missing: all my notification data for Wednesday was also gone. And there had been a lot of it.

It seemed to all hint at some kind of server problem.

I waited and reloaded the page over and over but eventually resigned myself to the photos were gone, along with all the amazing comments, likes and shares.

I left a bug report with FB, got an auto-reply but never heard from them.

The residual problem with my photo album gave me a small amount of hope a fix may yet be in the works, but I wasn’t going to hold my breath.

 

The ressurection

24 hours after I first noticed the images had gone, one returned. My homerun Wednesday photo was back (yay!) but the other one remained missing along with the missing notification data.

The album was also restored and the photos that had been in the album were now, once again, appearing as contents of that album and not just orphans.

So I figured it was time to repost the photo that was not recovered.

But when I did, I got a warning that the link posted with the photo had been flagged as spam.

What a clustrfck. Once again I ceased and desisted from re-uploading that photo.

But no matter, 12 hours later it re-appeared on its own. It had been offline 36 hours.

The missing notification data never reappeared.

 

Was moderation a part of the problem?

This happened around a time when I saw a lot of warning messages from FB when clicking external links.

FB put a “is this spam?” button at the top of the page when you clicked a link that would take you outside FB. If a few thousand people clicked the link, it’s pretty likely a few might have said “yes this is spam” even just accidentally. And anyone who wants to give you problems can easily tell FB it is spam.

The thing is, if it was because of a spam flag, the messaging on the missing photo should have been more informative instead of the bland generic 404-ish response.

 

So who knows: was it a server problem, a spam filter problem or both? Both photos and the album contained external links.

To be safe I removed all the links from my photos. I won’t be posting links with my photos anymore. This is probably as FB intends… not wanting anyone to leave the cocoon of the FB environment.

Shame.